2013.03.05

Linux

Oh Linux… sometimes you make it really hard to love you.

While the recent data rescue went well, other things have not been as easy. Let’s see where we are, shall we?

Home Server
This is the old dead-screen PowerBook that ran for years without issue. Until it had an issue. I rescued the data from it, and then I figured I would do a re-install of Linux on it, but so far it’s been all failure. The external VGA connection doesn’t seem to want to display anything, so without a screen to see the install, I don’t even know if it’s booting up properly. (This is a recurring theme, btw.)

Raspberry Pi
One of my Raspberry Pis occasionally hangs on boot. Sometimes. Other times it works fine. Since it’s headless I needed to attach it to a TV to see this. The other Raspberry Pi I have does have an HDMI-VGA adapter, which works when you edit config.txt properly. Sometimes. And yeah, my RF Modulator to use the composite video seems to have died, so that option was out as well. Also, the SD card cracked. These are all fairly minor things, but they add up.

(New) Xubuntu Laptop
While it’s a new machine to me, it’s a 10 year old laptop running Xubuntu. It was going to be (will be?) my new Lab Computer, controlling the RepRap, and hopefully running Octoprint, which won’t run on the Eee PC I now use to control the RepRap. I left it running with my account logged in and it went offline… kernel panic. Hmmm, let me check right now. Yeah, it’s hosed up. I try to ssh in and get ‘Input/output error’ so something isn’t right. Dammit.

Eee PC
Well, this little beast keeps chugging along. Besides the fact that it can’t do much, it can control the RepRap, and it does a pretty good job of not losing the wifi connection. All good.

Another One
Since I may need a replacement for the old PowerBook that was the Home Server, I figured I’d try an old G4 iMac with a dead display. Multiple attempts with Ubuntu Server and Xubuntu Desktop all failed. Won’t boot from a CD or DVD. I did read about an NVIDIA driver conflict, urgh. I may try some other distros, but I’m thinking it may be an issue with the fact that the built-in display is dead and the external VGA connection isn’t doing the right thing. Bummer.

Keep in mind I’m considered really good at this stuff… but I guess when shit goes wrong, it really goes wrong.

Comments are closed.

« | »


buy the button:

Buy The Button