posts tagged with the keyword ‘logic’

2010.12.12

Logic Express

Over the years I’ve become a fan of Apple’s Logic Studio (which I use at work) and Logic Express (which I use for personal projects.) They’re both pretty powerful applications for audio engineering. We’ve done a lot of good stuff with these apps.

About a year ago I tried using Apple’s Migration Assistant to move a user to a new Mac. There was some failure, mainly involving Final Cut Studio. I ended up having to call Apple and finally talked to a guy who straightened it out (it was serial number issues) and pretty told me to AVOID using Migration Assistant for Apple’s Pro Apps (Final Cut Studio, Logic Studio, Aperture.) He told me it doesn’t work… usually due to how the installs bind to the hardware of the machine, or something like that.

I’ll ignore the fact that Apple’s Migration Assistant can’t deal with it’s own applications properly for now… I’ve got Logic Express to deal with…

I finally got Migration Assistant to work really well on my last Mac move. Everything seemed fine. All of my applications, settings, etc. appeared to be in working order. All except for Logic Express 9.

No matter what I did, I could not launch it under my normal user account. I tried reboots, a reinstall, and nothing, It just hung there. I tried another reboot and reinstall. Nothing. I created a new user account, and it launched fine. Tried the install under the new user account, and it seemed fine. Went back to my user account… no good. I tried trashing it and another install, and this time it didn’t even show up in the Applications folder! I found this Apple Support Article: Pro Applications: Entering serial number after migrating causes the application to stop responding and tried to trash /Library/LaunchDaemons/com.apple.aelwriter.plist this didn’t work either. I was getting a little bit annoyed by now. I’ve been taking care of Macs professionally for 15 years, and this one had me a bit stumped. (And I wasn’t about to do a system reinstall!)

But finally… I fixed it! I ended up watching Console.app for a while when trying to launch Logic, and saw that it was trying to launch /usr/sbin/AELWriter which didn’t exist. I copied /usr/sbin/AELWriter to my new Mac from the original Mac I migrated from, and also copied /Library/LaunchDaemons/com.apple.aelwriter.plist as well, and we were back in business. Logic Express launched, asked for a serial number, I provided it, and it’s running right now.

I don’t give up easily.

|


buy the button:

Buy The Button